Bristlenose World
Don't forget to vote for Bristlenose World Smile




 
HomeHome  CalendarCalendar  GalleryGallery  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log in  

Share | 
 

 filter stinks of sulphur ?

View previous topic View next topic Go down 
AuthorMessage
davew
Large Bristlenose
Large Bristlenose


Number of posts : 172
Location : nottingham
Thank You Points : 17
Registration date : 2011-07-26

PostSubject: filter stinks of sulphur ?    Tue Jan 24, 2012 10:45 pm

hi guys,

question for you,

one of my juwel internal filters when disturbed stinks of possibly sulphur or something similar,

guessing this is not a good thing, its a partial bare bottem tank with a little bit of sand, so not enough to make gas pockets, it something with the filter,

thought it might be stagnant water or somthing if the power head has become a little blocked, but looked in and the water look like it was moving,

guessing its not good, have ran full water tests and have come back with nitrate and a nitrite reading.....

Amonia:0 i think
Nitrate:5
Nitrite:0.3

i say amonia is zero it usually is and i cannot test the water now as i have just done a water change and used PRIME as a declorinater, i was told it would give me false readings when used,
any way your thoughts on a sulphar smell ?

Back to top Go down
View user profile
jim.and
Moderator
Moderator


Male Number of posts : 1449
Age : 59
Location : England
Job/hobbies : Warehouse Op
Thank You Points : 107
Registration date : 2010-08-04

PostSubject: Re: filter stinks of sulphur ?    Wed Jan 25, 2012 12:02 am

It sounds like there is an anaerobic region within the filter and there is a bacterial build up, possibly heterotrophic bacteria, that is producing hydrogen sulfide, giving that rotten egg smell.

Possible causes are the filter has suffered a power failure or it's due a cleaning.
Back to top Go down
View user profile
davew
Large Bristlenose
Large Bristlenose


Number of posts : 172
Location : nottingham
Thank You Points : 17
Registration date : 2011-07-26

PostSubject: Re: filter stinks of sulphur ?    Wed Jan 25, 2012 1:16 am

ahhhh, possably right there Smile have give the sponges a clean in some tank water and cleaning the inside of the box, dropted a water change and monitoring,

SmileSmile

fingers crossed,
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: filter stinks of sulphur ?    Today at 1:31 pm

Back to top Go down
 
filter stinks of sulphur ?
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Bypass filter switch Pas-3
» Fry in filter bigger
» PAS 3X - loudness and filter switch
» Ph-15 filter
» How to use lime Sulphur

Permissions in this forum:You cannot reply to topics in this forum
Bristlenose World :: Bristlenose Main Area :: Tank/Water/Filters-
Jump to: